Installing sFlow codec in Logstash

Was trying to read some Sflow in logstash and noticed that the plugin does not come installed by default. It brings netflow in its plugins but no Sflow.. on to install it.

Trying to locate what is installed:

splabadmin@machine:/usr/share/logstash$ sudo find . -name codecs
./lib/pluginmanager/templates/codec-plugin/lib/logstash/codecs
./lib/pluginmanager/templates/codec-plugin/spec/codecs
./vendor/bundle/jruby/2.5.0/gems/logstash-codec-fluent-3.2.0-java/lib/logstash/codecs
./vendor/bundle/jruby/2.5.0/gems/logstash-codec-edn-3.0.6/lib/logstash/codecs

./logstash-core/lib/logstash/codecs

 

Installing it:

sudo /usr/share/logstash/bin/logstash-plugin install logstash-codec-sflow

Checking it again

splabadmin@machine:/usr/share/logstash$ sudo find . -name codecs
./lib/pluginmanager/templates/codec-plugin/lib/logstash/codecs
./lib/pluginmanager/templates/codec-plugin/spec/codecs
./vendor/bundle/jruby/2.5.0/gems/logstash-codec-sflow-2.1.3/lib/logstash/codecs
./vendor/bundle/jruby/2.5.0/gems/logstash-codec-sflow-2.1.3/spec/codecs
./vendor/bundle/jruby/2.5.0/gems/logstash-codec-fluent-3.2.0-java/lib/logstash/codecs

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *